import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bThank-you$).*";
final String string = "//site/us/count/Pages/product-a-Thank-you\n"
+ "//site/us/count/Pages/Information-b-Thank-you\n"
+ "//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you\n"
+ "//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}