$re = '/^(?!.*\bThank-you$).*/m';
$str = '//site/us/count/Pages/product-a-Thank-you
//site/us/count/Pages/Information-b-Thank-you
//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you
//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;