#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2},\d{1,2}(?:(?:x\d{1,2},\d{1,2}){2})?(?:cm|m[²2]?|kg)$"
Local $sString = "1,2m" & @CRLF & _
"2,3kg" & @CRLF & _
"13,2m2" & @CRLF & _
"4,44m²" & @CRLF & _
"33,2cm" & @CRLF & _
"1,3x1,0x0,7cm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")