import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,2},\\d{1,2}(?:(?:x\\d{1,2},\\d{1,2}){2})?(?:cm|m[²2]?|kg)$";
final String string = "1,2m\n"
+ "2,3kg\n"
+ "13,2m2\n"
+ "4,44m²\n"
+ "33,2cm\n"
+ "1,3x1,0x0,7cm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}