const regex = /^\d{1,2},\d{1,2}(?:(?:x\d{1,2},\d{1,2}){2})?(?:cm|m[²2]?|kg)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2},\\d{1,2}(?:(?:x\\d{1,2},\\d{1,2}){2})?(?:cm|m[²2]?|kg)$', 'gm')
const str = `1,2m
2,3kg
13,2m2
4,44m²
33,2cm
1,3x1,0x0,7cm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}