use strict;
my $str = '1,2m
2,3kg
13,2m2
4,44m²
33,2cm
1,3x1,0x0,7cm';
my $regex = qr/^\d{1,2},\d{1,2}(?:(?:x\d{1,2},\d{1,2}){2})?(?:cm|m[²2]?|kg)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}