package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2},\d{1,2}(?:(?:x\d{1,2},\d{1,2}){2})?(?:cm|m[²2]?|kg)$`)
var str = `1,2m
2,3kg
13,2m2
4,44m²
33,2cm
1,3x1,0x0,7cm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}