re = /^\d{1,2},\d{1,2}(?:(?:x\d{1,2},\d{1,2}){2})?(?:cm|m[²2]?|kg)$/m
str = '1,2m
2,3kg
13,2m2
4,44m²
33,2cm
1,3x1,0x0,7cm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end