using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((([a-z\d](-?[a-z\d]){0,62})\.)*(([a-z\d](-?[a-z\d]){0,62})\.)([a-z](-?[a-z\d]){1,62})|((\d{1,3}\.){3}\d{1,3}))$";
string input = @"// Valid
a-a.domain.com
1a.domain.com
a1.domain.com
a.domain.com
domain.com
10.10.10.11
// Invalid
-a.domain.com
a-.domain.com
// Valid
cname.do-main.com
cname.1domain.com
cname.domain1.com
// Invalid
cname.-domain.com
cname.domain-.com
// Valid
cname.domain.tld
cname.domain.co
cname.domain.tld1
cname.domain.tld-1
// Invalid
cname.domain.1tld
cname.domain.tld-
cname.domain.-tld";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}