const regex = new RegExp('^((([a-z\\d](-?[a-z\\d]){0,62})\\.)*(([a-z\\d](-?[a-z\\d]){0,62})\\.)([a-z](-?[a-z\\d]){1,62})|((\\d{1,3}\\.){3}\\d{1,3}))$', 'gm')
const str = `// Valid
a-a.domain.com
1a.domain.com
a1.domain.com
a.domain.com
domain.com
10.10.10.11
// Invalid
-a.domain.com
a-.domain.com
// Valid
cname.do-main.com
cname.1domain.com
cname.domain1.com
// Invalid
cname.-domain.com
cname.domain-.com
// Valid
cname.domain.tld
cname.domain.co
cname.domain.tld1
cname.domain.tld-1
// Invalid
cname.domain.1tld
cname.domain.tld-
cname.domain.-tld`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}