import Foundation
let pattern = #"^((([a-z\d](-?[a-z\d]){0,62})\.)*(([a-z\d](-?[a-z\d]){0,62})\.)([a-z](-?[a-z\d]){1,62})|((\d{1,3}\.){3}\d{1,3}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Valid
a-a.domain.com
1a.domain.com
a1.domain.com
a.domain.com
domain.com
10.10.10.11
// Invalid
-a.domain.com
a-.domain.com
// Valid
cname.do-main.com
cname.1domain.com
cname.domain1.com
// Invalid
cname.-domain.com
cname.domain-.com
// Valid
cname.domain.tld
cname.domain.co
cname.domain.tld1
cname.domain.tld-1
// Invalid
cname.domain.1tld
cname.domain.tld-
cname.domain.-tld
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)