import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((([a-z\\d](-?[a-z\\d]){0,62})\\.)*(([a-z\\d](-?[a-z\\d]){0,62})\\.)([a-z](-?[a-z\\d]){1,62})|((\\d{1,3}\\.){3}\\d{1,3}))$";
final String string = "// Valid\n"
+ "a-a.domain.com\n"
+ "1a.domain.com\n"
+ "a1.domain.com\n"
+ "a.domain.com\n"
+ "domain.com\n"
+ "10.10.10.11\n"
+ "// Invalid\n"
+ "-a.domain.com\n"
+ "a-.domain.com\n\n"
+ "// Valid\n"
+ "cname.do-main.com\n"
+ "cname.1domain.com\n"
+ "cname.domain1.com\n"
+ "// Invalid\n"
+ "cname.-domain.com\n"
+ "cname.domain-.com\n\n"
+ "// Valid\n"
+ "cname.domain.tld\n"
+ "cname.domain.co\n"
+ "cname.domain.tld1\n"
+ "cname.domain.tld-1\n"
+ "// Invalid\n"
+ "cname.domain.1tld\n"
+ "cname.domain.tld-\n"
+ "cname.domain.-tld";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}