import re
regex = re.compile(r"^((([a-z\d](-?[a-z\d]){0,62})\.)*(([a-z\d](-?[a-z\d]){0,62})\.)([a-z](-?[a-z\d]){1,62})|((\d{1,3}\.){3}\d{1,3}))$", flags=re.MULTILINE)
test_str = ("// Valid\n"
"a-a.domain.com\n"
"1a.domain.com\n"
"a1.domain.com\n"
"a.domain.com\n"
"domain.com\n"
"10.10.10.11\n"
"// Invalid\n"
"-a.domain.com\n"
"a-.domain.com\n\n"
"// Valid\n"
"cname.do-main.com\n"
"cname.1domain.com\n"
"cname.domain1.com\n"
"// Invalid\n"
"cname.-domain.com\n"
"cname.domain-.com\n\n"
"// Valid\n"
"cname.domain.tld\n"
"cname.domain.co\n"
"cname.domain.tld1\n"
"cname.domain.tld-1\n"
"// Invalid\n"
"cname.domain.1tld\n"
"cname.domain.tld-\n"
"cname.domain.-tld")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")