using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})";
string input = @"<iframe src=""https://www.youtube.com/embed/B2j51s2Zte4"" width=""580"" height=""418"" frameborder=""0"" allowfullscreen=""allowfullscreen""></iframe>
https://www.youtube.com/embed/B2j51s2Zte4
https://www.youtu.be/B2j51s2Zte4
http://youtube.com/v/B2j51s2Zte4
http://youtube.com/?v=B2j51s2Zte4
//youtube.com/watch?v=B2j51s2Zte4
youtu.be/B2j51s2Zte4
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}