// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})").unwrap();
let string = "<iframe src=\"https://www.youtube.com/embed/B2j51s2Zte4\" width=\"580\" height=\"418\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
https://www.youtube.com/embed/B2j51s2Zte4
https://www.youtu.be/B2j51s2Zte4
http://youtube.com/v/B2j51s2Zte4
http://youtube.com/?v=B2j51s2Zte4
//youtube.com/watch?v=B2j51s2Zte4
youtu.be/B2j51s2Zte4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}