import Foundation
let pattern = #"(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<iframe src="https://www.youtube.com/embed/B2j51s2Zte4" width="580" height="418" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
https://www.youtube.com/embed/B2j51s2Zte4
https://www.youtu.be/B2j51s2Zte4
http://youtube.com/v/B2j51s2Zte4
http://youtube.com/?v=B2j51s2Zte4
//youtube.com/watch?v=B2j51s2Zte4
youtu.be/B2j51s2Zte4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)