re = /(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})/i
str = '<iframe src="https://www.youtube.com/embed/B2j51s2Zte4" width="580" height="418" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
https://www.youtube.com/embed/B2j51s2Zte4
https://www.youtu.be/B2j51s2Zte4
http://youtube.com/v/B2j51s2Zte4
http://youtube.com/?v=B2j51s2Zte4
//youtube.com/watch?v=B2j51s2Zte4
youtu.be/B2j51s2Zte4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end