using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?(\d{4})<\/i>\)";
string input = @"<!DOCTYPE html PUBLIC ""-//IETF//DTD HTML 2.0//EN"">
<HTML>
<HEAD>
<TITLE>
A Small Hello
</TITLE>
</HEAD>
<BODY>
<H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P>
<H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal ""hello world"" HTML document.</P>
<i>1921</i>)
</BODY>
</HTML>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}