const regex = /.+?(\d{4})<\/i>\)/ms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?(\\d{4})<\\\/i>\\)', 'ms')
const str = `<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML>
<HEAD>
<TITLE>
A Small Hello
</TITLE>
</HEAD>
<BODY>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<i>1921</i>)
</BODY>
</HTML>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}