$re = '/.+?(\d{4})<\/i>\)/ms';
$str = '<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML>
<HEAD>
<TITLE>
A Small Hello
</TITLE>
</HEAD>
<BODY>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<i>1921</i>)
</BODY>
</HTML>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);