# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+?(\d{4})<\/i>\)"
test_str = ("<!DOCTYPE html PUBLIC \"-//IETF//DTD HTML 2.0//EN\">\n"
"<HTML>\n"
" <HEAD>\n"
" <TITLE>\n"
" A Small Hello\n"
" </TITLE>\n"
" </HEAD>\n"
"<BODY>\n"
" <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P>\n"
" <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P> <H1>Hi</H1>\n"
" <P>This is very minimal \"hello world\" HTML document.</P>\n"
"<i>1921</i>)\n"
"</BODY>\n"
"</HTML>")
matches = re.search(regex, test_str, re.MULTILINE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.