re = /.+?(\d{4})<\/i>\)/m
str = '<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML>
<HEAD>
<TITLE>
A Small Hello
</TITLE>
</HEAD>
<BODY>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<i>1921</i>)
</BODY>
</HTML>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end