package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms).+?(\d{4})<\/i>\)`)
var str = `<!DOCTYPE html PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML>
<HEAD>
<TITLE>
A Small Hello
</TITLE>
</HEAD>
<BODY>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P> <H1>Hi</H1>
<P>This is very minimal "hello world" HTML document.</P>
<i>1921</i>)
</BODY>
</HTML>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}