# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/dip=\"([^\"]*)\"([ ]dp=\"[^\"]*\")(?:[ ]nat-dip=\"(\1)\"|([ ]nat-dip=\"([^\"]*)\"))/dip="\3\5"\2\4/g;t' <<< "sip=\"100.107.0.5\" sp=\"123\" dip=\"100.107.193.1\" dp=\"123\" nat-dip=\"84.2.44.19\"
sip=\"100.101.199.1\" sp=\"37690\" dip=\"100.107.0.4\" dp=\"80\" nat-dip=\"100.107.0.4\""