# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"dip=\"([^\"]*)\"([ ]dp=\"[^\"]*\")(?:[ ]nat-dip=\"(\1)\"|([ ]nat-dip=\"([^\"]*)\"))"
test_str = ("sip=\"100.107.0.5\" sp=\"123\" dip=\"100.107.193.1\" dp=\"123\" nat-dip=\"84.2.44.19\"\n"
"sip=\"100.101.199.1\" sp=\"37690\" dip=\"100.107.0.4\" dp=\"80\" nat-dip=\"100.107.0.4\"")
subst = "dip=\"\\3\\5\"\\2\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.