re = /dip=\"([^\"]*)\"([ ]dp=\"[^\"]*\")(?:[ ]nat-dip=\"(\1)\"|([ ]nat-dip=\"([^\"]*)\"))/
str = 'sip="100.107.0.5" sp="123" dip="100.107.193.1" dp="123" nat-dip="84.2.44.19"
sip="100.101.199.1" sp="37690" dip="100.107.0.4" dp="80" nat-dip="100.107.0.4"'
subst = 'dip="\\3\\5"\\2\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result