using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dip=\""([^\""]*)\""([ ]dp=\""[^\""]*\"")(?:[ ]nat-dip=\""(\1)\""|([ ]nat-dip=\""([^\""]*)\""))";
string substitution = @"dip=""\3\5""\2\4";
string input = @"sip=""100.107.0.5"" sp=""123"" dip=""100.107.193.1"" dp=""123"" nat-dip=""84.2.44.19""
sip=""100.101.199.1"" sp=""37690"" dip=""100.107.0.4"" dp=""80"" nat-dip=""100.107.0.4""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}