import Foundation
let pattern = #"dip=\"([^\"]*)\"([ ]dp=\"[^\"]*\")(?:[ ]nat-dip=\"(\1)\"|([ ]nat-dip=\"([^\"]*)\"))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
sip="100.107.0.5" sp="123" dip="100.107.193.1" dp="123" nat-dip="84.2.44.19"
sip="100.101.199.1" sp="37690" dip="100.107.0.4" dp="80" nat-dip="100.107.0.4"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"dip="\3\5"\2\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)