#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*time\s+(\d{2}:\d{2}\s(am|pm)).*"
Local $sString = "there is some text and maybe some number or symbols time 12:32 am and there is some text"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)