import Foundation
let pattern = #".*time\s+(\d{2}:\d{2}\s(am|pm)).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"there is some text and maybe some number or symbols time 12:32 am and there is some text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}