$re = '/.*time\s+(\d{2}:\d{2}\s(am|pm)).*/';
$str = 'there is some text and maybe some number or symbols time 12:32 am and there is some text';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;