use strict;
my $str = 'there is some text and maybe some number or symbols time 12:32 am and there is some text';
my $regex = qr/.*time\s+(\d{2}:\d{2}\s(am|pm)).*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";