// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*time\s+(\d{2}:\d{2}\s(am|pm)).*").unwrap();
let string = "there is some text and maybe some number or symbols time 12:32 am and there is some text";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}