using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*time\s+(\d{2}:\d{2}\s(am|pm)).*";
string substitution = @"";
string input = @"there is some text and maybe some number or symbols time 12:32 am and there is some text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}