using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+A Line[0-9]+(?: \w+)+";
string input = @"1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}