$re = '~[0-9]+A Line[0-9]+(?: \w+)+~im';
$str = '1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);