use strict;
my $str = '1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail';
my $regex = qr~[0-9]+A Line[0-9]+(?: \w+)+~imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}