package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)[0-9]+A Line[0-9]+(?: \w+)+`)
var str = `1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}