// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)[0-9]+A Line[0-9]+(?: \w+)+").unwrap();
let string = "1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}