re = /[0-9]+A Line[0-9]+(?: \w+)+/im
str = '1A Line1 Detail1 Detail2 Detail3 2A Line2 Detail 3A Line3 Detail Detail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end