import re
regex = re.compile(r"{{((\w+)(.\w+|\[\d+\])+?)}}")
test_str = "Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")