re = /{{((\w+)(.\w+|\[\d+\])+?)}}/
str = 'Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end