// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"{{((\w+)(.\w+|\[\d+\])+?)}}").unwrap();
let string = "Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}