#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d*#\D)|(\d*#^)"
Local $sString = ""8617722824323#312|86259920#None17722825198#"" & @CRLF & _
"1777213134#|+8617722824323#" & @CRLF & _
"8617722824323#312" & @CRLF & _
"1777213134#" & @CRLF & _
"8617722824323#312"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")