// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d*#\D)|(\d*#^)").unwrap();
let string = "\"8617722824323#312|86259920#None17722825198#\"
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}