$re = '/(\d*#\D)|(\d*#^)/m';
$str = '"8617722824323#312|86259920#None17722825198#"
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);