import re
regex = re.compile(r"(\d*#\D)|(\d*#^)", flags=re.MULTILINE)
test_str = ("\"8617722824323#312|86259920#None17722825198#\"\n"
"1777213134#|+8617722824323#\n"
"8617722824323#312\n"
"1777213134#\n"
"8617722824323#312")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")