package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*#\D)|(\d*#^)`)
var str = `"8617722824323#312|86259920#None17722825198#"
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}