const regex = new RegExp('(\\d*#\\D)|(\\d*#^)', 'mg')
const str = `"8617722824323#312|86259920#None17722825198#"
1777213134#|+8617722824323#
8617722824323#312
1777213134#
8617722824323#312`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}