#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*\[(?P<id>\d+)\]\s*:\s*(?P<link>[^\n]+)$"
Local $sString = "This is a sample doucument that would have inline links. " & @CRLF & _
"[Example 0][0], [Example 1][1], [Example 2][2] , [Example 3][3] , [Example 4][4]" & @CRLF & _
"" & @CRLF & _
"[0]: http://example.com" & @CRLF & _
" [1]: http://example.com/1" & @CRLF & _
" [2] : http://example.com/2" & @CRLF & _
" [3]: http://example.com/3" & @CRLF & _
" [4] : http://example.com/4"
Local $sSubst = "[\1]: \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)